跳转到内容
登录关注  
Qing.Su

LiteSpeed PHP编译安装Imagick拓展

已推荐帖子

昨天,Wordpress报错,“您的服务器不支持图片剪裁。”搜索了一下,有两种可能会导致这种情况,第一种是没有安装php-gd组件,第二种是没有安装Imagick拓展。仔细研究了一下,发现我之前装系统的时候没有给PHP安装Imagick拓展。今天在这里记录一下编译安装Imagick的方法。

我们的操作环境是Ubuntu 18.04 LTS 64 bit, LiteSpeed v5.4, LSPHP v7.4. 如果您使用的是Apache或者Nginx, 那么大概率你装的是PHP而不是LSPHP,因此不需要这么麻烦地编译安装。

首先,我们安装必要的编译环境。

1
apt-get install libmagickwand-dev pkg-config build-essential autoconf

然后下载Imagick源文件包。官网下载链接在这里:http://pecl.php.net/package/imagick, 比如我们这里下载最新的3.4.4版本。

1
2
3
wget http://pecl.php.net/get/imagick-3.4.4.tgz
tar zxvf i*.tgz
cd imagick-3.4.4

下载的源文件不能直接编译安装,需要首先用phpize搭建符合PHP的编译环境。我们在刚刚imagick文件夹里,执行phpize命令:

1
/usr/local/lsws/lsphp74/bin/phpize

然后就是传统的配置及编译安装了。

1
2
3
./configure --with-imagick=/usr/local/lsws/lsphp74 --with-php-config=/usr/local/lsws/lsphp74/bin/php-config
make
make install

安装完毕后,编辑php.ini文件,在末尾加上:

1
extension = imagick.so

最后,重启LiteSpeed服务器,Imagick拓展就装好啦。

1
/usr/local/lsws/bin/lswsctrl restart

如果您有任何疑问,欢迎留言与我讨论。本文作者为香菇肥牛,本文链接为https://qing.su/article/147.html, 转载请注明原文链接,谢谢!

查看完整帖子

分享这篇帖子


链接帖子

参与讨论

你现在可以发表并稍后注册。 如果你有帐户,现在就登录参与讨论。

游客
回复主题...

×   粘贴为富文本.   粘贴为纯文本来代替

  只允许使用75个表情符号.

×   你的链接已自动嵌入.   显示为链接来代替

×   你之前的内容已恢复.   清除编辑器

×   你无法直接粘贴图片。要从网址上传或插入图片。

登录关注  

×
×
  • 创建新的...